Home > Dpkg Error > Dpkg Error Processing Slapd -configure

Dpkg Error Processing Slapd -configure

dpkg: error processing > /var/cache/apt/archives/slapd_2.4.28-1.1ubuntu4.6_amd64.deb > (--unpack): subprocess new pre-removal script returned error exit > status 1 Backing up /etc/ldap/slapd.d in > /var/backups/slapd-2.4.28-1.1ubuntu4.6... Copy sent to Torsten Landschoff . I have attempted to remove everything in the /var/lib/ldap directory (the place where slapd.conf says ldbm lives), but that didn't work. The time now is 02:12 PM. http://thewebparrots.com/dpkg-error/dpkg-error-processing-top-configure.php

User contributions on this site are licensed under the Creative Commons Attribution Share Alike 4.0 International License. Here is the error I got: sevan:~# apt-get install slapd Reading Package Lists... Do "accountable", "responsible", "answerable" imply "blamable"? Files: 5c9c162271f89989b3f2369db42449e4 952 net optional openldap2_2.1.17-3.dsc b6a2c424ac9f23937e01747acb0af760 49151 net optional openldap2_2.1.17-3.diff.gz 13b00261120b6ad8736db55b24b6e1fc 975704 net optional slapd_2.1.17-3_i386.deb 12da093d177d3153f1722db064292909 90324 net optional ldap-utils_2.1.17-3_i386.deb 2864fdb5eddcfdbd9bef0dc56f7fea75 255160 libs important libldap2_2.1.17-3_i386.deb 75ab977120b695302b50723d4c40be8b 288362 libdevel extra libldap2-dev_2.1.17-3_i386.deb

Closes: #194740 + Add space before ']' on line 113 of postinst. PS> please delete the closed question on stackoverflow. If no, I would suggest you to restore the ZCS 8.0.9 with backup and then try upgrading again.If yes, then please follow the following steps1) cd zcs-8.0.9_GA_6191.UBUNTU12_64.20141103151539/packages2) dpkg -i zimbra-ldap_8.0.9.GA.6191.UBUNTU12.64_amd64.deb3) su

done. Edit bug mail Other bug subscribers Subscribe someone else Bug attachments Dependencies.txt (edit) Df.txt (edit) Dmesg.txt (edit) DpkgTerminalLog.gz (edit) Add attachment • Take the tour • Read the guide © done. After unpacking 4162 kB will be freed.dpkg: error processing slapd (--remove): Package is in a very bad inconsistent state - you should reinstall it before attempting a removal.configured to not write

Zimbra isn't functioning and updater want's LDAP to be active.This command was run:[email protected]:/opt/zcs-8.7.0_GA_1659.UBUNTU12_64.20160628202549# ./install.sh --force-upgrade --skip-activation-check --skip-upgrade-checkOperations logged to /tmp/install.log.rJseaZunChecking for existing installation... Closes: #192163. + debian/rules: Added binary-indep to the binary: build line and flushed it out to build the libslapd2-dev deb. After unpacking 3224kB will be used. > Preconfiguring packages ... > (Reading database ... 134016 files and directories currently installed.) > Unpacking slapd (from .../slapd_2.1.17-2_i386.deb) ... > Checking if LDAP directory click to read more Done > > The following NEW packages will be installed: > > slapd > > 0 packages upgraded, 1 newly installed, 0 to remove and 342 not upgraded. > > Need

How do I mark 'Invalid'? Moved and commented out 'replogfile' since it is database specific, wasn't doing anything where it was and use of it depends on slurpd usage. https://bugs.launchpad.net/bugs/796329 Title: package slapd 2.4.23-6ubuntu6 failed to remove: subprocess installed pre-removal script returned error exit status 1 To manage notifications about this bug go to: https://bugs.launchpad.net/ubuntu/+source/openldap/+bug/796329/+subscriptions Previous message: [Bug 796329] Re: Not sure how to check for the full package at that time but somehow we have to manage that ;) Thanks and Greetings Torsten [Message part 2 (application/pgp-signature, inline)] Information forwarded

What should I do? https://lists.debian.org/debian-user/2005/06/msg02501.html Writing referee report: found major error, now what? Torsten Landschoff (supplier of updated openldap2 package) (This message was generated automatically at their request; if you believe that there is a problem with it please contact the archive administrators Several machines have been successfully set up using this method.

Closes: #194192, #194943 . * Torsten Landschoff : + debian/control: Enforce libldap2 to be the same version as slapd as slapd (legitimately) uses internal functions of that library (closes: #190164). + check my blog Done > The following NEW packages will be installed: > slapd > 0 packages upgraded, 1 newly installed, 0 to remove and 342 not upgraded. > Need to get 0B/968kB of dpkg - warning: while removing slapd, directory `/etc/ldap' not empty so not removed. Not sure how to check for the full package at > that time but somehow we have to manage that ;) Isn't this fixed by the patches I submitted, which remove

Message #20 received at [email protected] (full text, mbox, reply): From: Steve Langasek To: Torsten Landschoff , [email protected] Cc: Benjamin Drieu Subject: Re: [debian-openldap] Bug#195029: slapd: won't install : "slapcat: You had slapd 2.0.23-14 installed, right? dpkg: error while cleaning up: > subprocess installed post-installation script returned error exit > status 1 Errors were encountered while processing: > /var/cache/apt/archives/slapd_2.4.28-1.1ubuntu4.6_amd64.deb E: > Sub-process /usr/bin/dpkg returned an error code http://thewebparrots.com/dpkg-error/dpkg-error-processing-ssl-cert-configure.php No further changes may be made.

Need to get 0B/817kB of archives. Done > > Building Dependency Tree... Unpacking replacement ldap-gateways ...

Attempting debug start to determine error.I will try with clean update path and report back, if I do apt clean before starting the 8.7 installer Top rkosir Posts: 5 Joined: Tue

ldap_bind: Can't contact LDAP server (81) > no > Dumping directory to /var/backups/slapd-2.0.23-14.ldif... /var/lib/dpkg/tmp.ci/preinst: line 145: slapcat: command not found Okay, this probably is a known bug. Notification sent to Benjamin Drieu : Bug acknowledged by developer. It is currently not supported. Can you try to clean cached data of apt and re-build using "apt-get clean" and "apt-get update".

grep: > /etc/ldap/slapd.d/cn=config/olcDatabase*: No such file or directory * > The pidfile for slapd has not been specified invoke-rc.d: initscript > slapd, action "start" failed. Is it a fallacy, and if so which, to believe we are special because our existence on Earth seems improbable? Acknowledgement sent to Steve Langasek : Extra info received and forwarded to list. have a peek at these guys vBulletin 2000 - 2016, Jelsoft Enterprises Ltd.

Is there anything wrong with this more symmetric aircraft design, and why isn't it used? Done The following NEW packages will be installed: slapd 0 packages upgraded, 1 newly installed, 0 to remove and 342 not upgraded. How do I resolve this? > Suggested packages: ldap-utils The following packages will be > upgraded: slapd 1 upgraded, 0 newly installed, 0 to remove and 68 not > upgraded. 1 Term for "professional" who doesn't make their living from that kind of work Tenant claims they paid rent in cash and that it was stolen from a mailbox.

See https://forums.zimbra.org/viewtopic.php?f=8&t=59816Thinking of upgrading your OS to Ubuntu 16.04 LTS? dpkg: error processing slapd (--remove): subprocess installed pre-removal script returned error exit status 1 -- You received this bug notification because you are a member of Ubuntu Server Team, which is Post Reply Print view Search Advanced search 9 posts • Page 1 of 1 rkosir Posts: 5 Joined: Tue Aug 02, 2016 12:45 pm Upgrade on Ubuntu fails from Zimbra 8.0.9 Closes: #151511 + debian/copy_slapd_dev_files: Added to copy the include files for building slapd back-ends. + debian/control: Add warning about libslapd2-dev + debian/control: Add build-depend on po-debconf for dh_installdebconf + debian/slapd.default: Add

I consider this solving #151511 since we don't ask if you want to use replication anymore anyway. These should only be bumped when new symbols are added so we should figure out a way to handle checking that. + debian/slapd.dirs: Added /var/run/slapd for pidfile + debian/slapd.conf: Moved pidfile Mark as duplicate Convert to a question Link a related branch Link to CVE You are not directly subscribed to this bug's notifications. The script fails to notice that the config is here despite the > package being unavailable.