Home > Dpkg Error > Dpkg Error Processing Postgresql-8.4 -purge

Dpkg Error Processing Postgresql-8.4 -purge

Trying to recover: Setting up postgresql-8.4 (8.4.2-0ubuntu9.10) ... * Starting PostgreSQL 8.4 database server * The PostgreSQL server failed to start. you have to edit the file and add set -x at the start of ssl-cert.postinst. –Braiam Sep 6 '13 at 16:58 Is your machines' FQDN very long? –200_success Sep Please check the log output: failed! dpkg: error processing postgresql (--configure): dependency problems - leaving unconfigured Errors were encountered while processing: postgresql-8.4 postgresql-contrib-8.4 postgresql-contrib postgresql Recursive dependencies: postgresql-8.4 depends: postgresql-8.4 ProblemType: Package DistroRelease: Ubuntu 10.04 Package: postgresql-8.4 http://thewebparrots.com/dpkg-error/dpkg-error-processing-postgresql-9-1-configure.php

Report a bug This report contains Public information Edit Everyone can see this information. dpkg: error processing postgresql-contrib (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of postgresql: postgresql depends on postgresql-8.4; however: Package postgresql-8.4 is not configured yet. Starting PostgreSQL 8.4 database server: main. Thanks!

Setting up postgresql-8.4 (8.4.2-0ubuntu9.10) ... Preparing to replace postgresql-doc 8.4.0-1 (using .../postgresql-doc_8.4.0-2_all.deb) ... Affecting: postgresql-8.4 (Ubuntu) Filed here by: Hal Lewis When: 2011-05-18 Completed: 2016-04-15 Target Distribution Baltix BOSS Juju Charms Collection Elbuntu Guadalinex Guadalinex Edu Kiwi Linux nUbuntu PLD Linux Tilix tuXlab Ubuntu Preparing to replace postgresql-8.4 8.4.0-1 (using .../postgresql-8.4_8.4.0-2_i386.deb) ...

I changed all lines in 'pg_hba.conf' to end with 'md5' versus some of them ending in 'ident'. Done Building dependency tree Reading state information... Message #15 received at [email protected] (full text, mbox, reply): From: Arthur Marsh To: Martin Pitt Cc: [email protected] Subject: Re: Bug#536656: postgresql-8.4: fails to restart after upgrade Date: Mon, 13 If I use 'sudo -u postgres psql postgres' to connect, no problem.

postgresql-8.4 depends on ssl-cert; however: Package ssl-cert is not configured yet. invoke-rc.d: initscript postgresql-8.4, action "start" failed. Is there anything wrong with this more symmetric aircraft design, and why isn't it used? look at this web-site We have to look for the line that begins with that begins unix_socket_directory and change it to read as the following: unix_socket_directory='/tmp' Now start the postgresql server using: sudo service postgresql

Starting PostgreSQL 8.4 database server: mainThe PostgreSQL server failed to start. Ask Ubuntu works best with JavaScript enabled UbuntuCommunityAsk!DeveloperDesignDiscourseHardwareInsightsJujuShopMore ›AppsHelpForumLaunchpadMAASCanonical current community chat Ask Ubuntu Ask Ubuntu Meta your communities Sign up or log in to customize your list. update-rc.d: error: insserv rejected the script header dpkg: error processing postgresql-8.4 (--configure): subprocess installed post-installation script returned error exit status 1 dpkg: dependency problems prevent configuration of postgresql: postgresql depends on dpkg: error processing postgresql-common (--configure): dependency problems - leaving unconfigured No apport report written because the error message indicates its a followup error from a previous failure.

more hot questions question feed about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation Science failed! insserv: script postgresql-8.4: service postgresql already provided! I purged all packages related to postgresql, tried to reinstall postgresql-common package only.

invoke-rc.d: initscript postgresql-8.4, action "start" failed. check my blog Still error was occuring. Please check the log output:' + res=1 + set -e + '[' 1 -eq 0 ']' + '[' 1 -eq 2 ']' + status=1 + '[' 1 -ne 0 -a -n but some time later: /etc/init.d/postgresql-8.4 restart Restarting PostgreSQL 8.4 database server: main.

That was done first, but seemed to have no effect. dpkg: error processing postgresql-8.4 (--configure): subprocess installed post-installation script returned error exit status 1 dpkg: dependency problems prevent configuration of postgresql: postgresql depends on postgresql-8.4; however: Package postgresql-8.4 is not configured When I add set -x to the top of the file, and then run the sudo ... http://thewebparrots.com/dpkg-error/dpkg-error-processing-purge.php Last modified: Sun Oct 9 13:14:31 2016; Machine Name: buxtehude Debian Bug tracking system Copyright (C) 1999 Darren O.

Setting up postgresql (8.4.0-2) ... Acknowledgement sent to Dennis Gearon : Extra info received and forwarded to list. Dennis Gearon Signature Warning ---------------- EARTH has a Right To Life,   otherwise we all die.

Powered by vBulletin Version 4.2.2 Copyright © 2016 vBulletin Solutions, Inc.

I purged the postgresql related packages and tried to install both postgresql-8.4 and postgresql-9.1, in both cases, it failed due to the dependency to postgresql-common package. 12.04 software-installation postgresql share|improve this Setting up postgresql-client-8.4 (8.4.0-2) ... Bad return status for module build on kernel: 2.6.37-64 (i686)Consult the make.log in the build directory/var/lib/dkms/virtualbox-guest/4.0.10/build/ for more information.dpkg: error processing virtualbox-guest-dkms (--configure):subprocess installed post-installation script returned error exit status 10dpkg: Can two different firmware files have same md5 sum?

Acknowledgement sent to Arthur Marsh : New Bug report received and forwarded. These are mapped to each other in pg_hba.conf: http://www.postgresql.org/docs/8.4/interactive/client-authentication.html http://www.postgresql.org/docs/8.4/interactive/user-manag.html "psql -U postgres" won't (and isn't supposed to) work with ident authentication, since by default the postgres system user has no Please check the log output: > 2009-12-20 02:41:47 EST LOG: invalid IP mask "trust": Name or service not > known > 2009-12-20 02:41:47 EST CONTEXT: line 110 of configuration file > have a peek at these guys I still get the same error, only fewer because I am only trying to install one component: The engine itself.

Not the answer you're looking for? It mostly went well but during the upgrade process and any time I run dpkg, aptitude or synaptic it gripes about postgresql. Any ideas?